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Word cross reference not showing all headings

01-26-2018, 12:28 AM Expert Join Date: Jan 2012 Location: Brussels [BE] Posts: 743 insert cross-reference - why is a Level 2 style not a headline? I was sent a document for review and noticed that some cross-references seemed to have been entered by hand. Tsk, tsk! I thought ... but when I took a closer look I became more sympathetic: the document contains a style based
on heading 2 and defined as Outline Level 2, but this style does not appear in the paragraph list when you select Insert &gt; Cross-Reference &gt; Reference Type: Heading Strangely Enough, the appropriate level 2 style appears in the document structure pane... Is there a solution? Attached images enAppx.png (45.5 KB, 10 views) 01-26-2018, 12:40 Expert Join Date: Jan 2012
Location: Brussels [BE] Posts: 743 I also notice that the two headings in question appear correctly in the table of contents ... (I would have edited the post instead of adding a reply, but clicking the Edit link shows a blank topic instead of my content) 01-26-2018, 6:12 Moderator Join date: Mar 2012 Location: Sun Prairie, Wisconsin Post: 7082 Why use Microsoft Word built-in
headline styles? by Shauna Kelly The built-in headlines have special properties. Assigning an outline level to a style does not give it these properties. I don't know if one based on a built-in heading carries these characteristics. Looking at the screen I see nothing missing from the cross-reference dialog box that appears in the Navigation Pane. P.S. I've noticed the occasional
blanking of the edit box as well. [Edit: When experimenting and further reading, styles based on the built-in heading styles are not displayed in the cross-reference dialog box as headings, even if they appear in the navigation pane and table of contents. See #15 of Shauna's cross-references article.] Last edited by Charles Kenyon; 01-29-2018 at 07:10 AM. 01-29-2018, 02:27 AM
Expert Join Date: Jan 2012 Location: Brussels [BE] Posts: 743 What is missing are the last two 'Attachments' entries, which appear in the document overview and ToC as level 2 headers but are not picked up by cross-references dialog. When it comes to using the built-in styles, that's where I started from with the style based on option. 01-29-2018, 5:12 AM Administrator Join
Date: December 2010 Location: Canberra, Australia Posts: 20677 If you refer to the selected 'Fill out Repair-RMA form' entry, I can see that in both the outline pane and insert | Cross-reference dialog. In fact, there seems to be a 1:1 correspondence between the entries displayed in Insert | Cross-reference dialog and the same area in the outline pane. The attachments would be
below these, but I can't see from your screen about Insert | Cross-reference dialog is scrolled all the way to the bottom. ______ Cheers, Paul Edstein [Fmr MS MVP - Word] 01-29-2018, 7:02 AM Moderator Join: Mar 2012 Location: Sun Prairie, Wisconsin Post: 7082 Quote: Written by macropod If you refer to the selected 'Fill repair-RMA form' entry, I can see that in both the outline
pane and insert| Cross-reference dialog. In fact, there seems to be a 1:1 correspondence between the entries displayed in Insert | Cross-reference dialog and the same area in the outline pane. The attachments would be below these, but I can't see from your screen about Insert | Cross-reference dialog is scrolled all the way to the bottom. I was. I note in looking into the fact that
the cross-reference dialog scroll bar shows that it is at the end of the list. The attachments appear at the bottom of the navigation pane and are not in the cross-reference list. I had assumed that they were cut off as were they at the top of the navigation pane. Either way, styles other than the nine built-in heading styles appear under headings in the cross-reference list, even if they
are based on heading styles and have an outline level. The work around is the method discussed in Shauna Kelly's article, in fact, using the built-in heading styles 6-9 that are often not used. 01-29-2018, 23:43 Expert Join Date: Jan 2012 Location: Brussels [BE] Posts: 743 Oh. I understand. Use level 6 heading style to fake a level 2 heading... Thanks for the tip, though; I wouldn't
have thought about it myself ;-} 01-30-2018, 6:00 Am Moderator Join Date: Mar 2012 Location: Sun Prairie, Wisconsin Post: 7082 Quote: Oh. I understand. Use level 6 heading style to fake a level 2 heading... Thanks for the tip, though; I wouldn't have thought about it myself ;-} I wouldn't have thought about it either, but Shauna Kelly did! Whoa! I came across an error in Word
2013, and checked if it also happened in Word 2010 (yep). It's possibly in earlier versions too, although I can't remember getting over it in these. This error could have existed for years, but I just never had this combination of circumstances that caused it to happen. It's likely that you might not find out what's causing it. So here's what I discovered with some testing ... If you: have
turned on track changes, and then delete the first few letters or words in a heading (that is, text with a heading style, whether outline numbered or not), and don't accept these changes, the heading text (and number if you use heading numbering) disappears from the Cross-Reference dialog box (under Headings), and you can't select the heading you want to make a cross-
reference to. I'm not talking about deleting an entire headline - it would be expected behavior. I'm talking about deleting the first letter at the beginning of a headline! Letters or words deleted in a heading still display the heading in the Cross-Reference dialog box, but NOT if you deleted the first letter. Accepting the tracked change is one solution — the heading appears again in the
Cross-Reference dialog box (under Headings), and then. However, this is NOT a satisfactory solution for where the track changes must be displayed for the client (e.g. for a authority wishing to see any changes made to the original document). However, if you use outlined headings, the header appears under the Numbered Items reference type in the Cross-Reference dialog box.
Related to this is a blog post I wrote several years ago on missing cross-references for table and shape captions where track changes had been turned on which resulted in the caption numbering changing when tables/numbers were added/deleted from the document: [Link last checked September 2015] This article helps you understand why problems can occur with cross-
references and how to resolve cross-reference issues in Word.You may sometimes find that one or more cross-reference fields in a document do not display the correct content. You may experience cross-reference fields that are not updated even if you changed the referenced item, such as a heading. The problem may also be that one or more fields refer to Section No. Finally,
the problem may be that one or more fields contain a lot of text where you expected only a reference to a heading. This article explains how these errors occur and how to manually fix and prevent them. The article also introduces you to DocTools CrossReferenceManager— an advanced Word add-in that makes cross-reference work much faster and easier and can help you repair
and prevent cross-reference problems in the future. Changed 9/23/2019. Videos are renewed to work without using Adobe Flash Player. Added information about more issues and how to fix them: Problem 5 and Problem 6.DocTools CrossReferenceManager is an advanced Word add-in that makes it easier and smarter than ever to work with cross-references in Word.The add-in
works with Microsoft Word 2010 and later versions on PC/Windows.DocTools CrossReferenceManager allows you to do everything you can do using the built-in cross-reference functionality of Word easier and faster. In addition, DocTools CrossReferenceManager includes smart and effective cross-reference features that are not found elsewhere. For example, you can save
language-specific custom cross-reference texts that contain placeholders for multiple cross-reference fields and insert the text, including all cross-references, with a single click. See the example below (field shadow laying is enabled to make it easy to identify fields):Among the features are also special tools for detecting and handling cross-reference errors:The add-in contains a
command that checks the document for errors— such as the cross-reference errors described on this page — and contains tools to repair any errors found. Additionally, the add-in includes functionality that can prevent certain types of errors. You can access the functionality of the add-in a custom tab on the ribbon. This advanced add-on is not free, but the return on investment is
Immediate. It will make all your future work with cross-reference faster and easier. Click the button below to learn more about DocTools CrossReferenceManager or to purchase the add-in. You can try DocTools CrossReferenceManager risk-free for 7 days. READ MORE - 7 Day Free TrialRead below if you want to find and fix the cross-reference issues manually instead of letting
the DocTools CrossReferenceManager add-in help you. General tip on how to work with fields in documentsA cross-reference is a field, that is, the set of codes that instructs Microsoft Word to insert material automatically into a document. The material can be text, page numbers, section numbers, graphics, etc. Fields can be displayed with gray shading on the screen, making it
easy to separate fields from normal text. Note that shading fields is not printed. Field shading can be turned on via Tools &gt; Options &gt; View tab. You can choose to display field shading Never, Always, or When selected. See the illustration below. If Microsoft Word 2007 finds the Field shading option as follows: Office Button &gt; Word Options &gt; Advanced Category &gt;
Show Document Content Group &gt; Field Shading. If Microsoft Word 2010 or later version, you can find the Field shading option as follows: File &gt; Options &gt; Advanced category &gt; Show Document Content Group &gt; Field Shading. I recommend that you always show shading of fields when working with documents that contain fields. If you don't see the fields, you run the
risk of making changes that are lost when you update fields. Setting field shading to Always also makes it much easier to find cross-reference issues. About the videos in this article Note that the videos were originally created by using Microsoft Word 2003. However, the problems and solutions are exactly the same in all newer versions of Word – but the user interface is different.
This means that the methods displayed in the videos apply to Word 2007 and all newer Word versions as well. For example, the videos show the Bookmark dialog box. In Microsoft Word 2007 or later version, you can open the Bookmark dialog box via the Insert tab &gt; Links-&gt; Bookmark. You can also press Ctrl+Shift+F5 to open the Bookmark dialog box. The videos also
refer to the display of formatting marks. Formatting marks can be toggle on and off in all versions of Word by using the Ctrl+Shift+8.Situation shortcut: You've made changes to one or more headings or other items that are cross-referenced in your document. However, the cross-reference fields still show the old text even if you update all the fields. Watch the video below for an
explanation of how the problem occurs and how to resolve it. The video also explains what to do to prevent such errors. The key to the problem is to be found in the way you edit cross referenced items. As mentioned above the video originally created using Microsoft Word 2003. However, the fixes and solutions are exactly the same in all newer versions of Word.Note at DocTools
DocTools the add-in can automatically prevent or resolve this issue. If the problem occurs in relation to a cross-reference to a numbered paragraph in a table, see also Issue 4 below. Situation: One or more cross-reference fields that should have referenced a heading number (or other numbered item) refer to section no. Alternatively, one or more fields refer to the wrong number
after updating fields. Watch the video below for an explanation of how the problem occurs and how to resolve it. The video also explains what to do to prevent such errors. For issue 1 described above, the key to the problem is to find in the way you edit cross-reference items. As mentioned above, the video was originally created using Microsoft Word 2003. However, the fixes and
solutions are exactly the same in all newer versions of Word.Note that the DocTools CrossReferenceManager add-in can automatically prevent or resolve this issue. Situation: One or more cross-reference fields that should have referenced the text in a heading or other item contain too much text after updating fields. You can even see tables or images that are included in a cross-
reference. Watch the video below for an explanation of how the problem occurs and how to resolve it. The video also explains what to do to prevent such errors. For issues 1 and 2 described above, the key to the problem is to find in the way you edit cross-reference items. As mentioned above, the video was originally created using Microsoft Word 2003. However, the fixes and
solutions are exactly the same in all newer versions of Word.Note that the DocTools CrossReferenceManager add-in can automatically prevent or resolve this issue. Situation: You insert a cross-reference to a numbered item in a table. Instead of displaying the number you selected, the cross-reference displays 0 or the wrong number after updating fields. See the two illustrations
below. In both illustrations, the cross-references showing 0 and A refer to the yellow 1st and 2nd in the table and should have shown 1st and 2nd. Formatting marks appear so that you can see that the numbered paragraphs in the yellow column/paragraphs do not contain text after the number and category. This issue is caused by an error in Word that exists in all Word versions at
least since Word 2003. The problem occurs if you insert a cross-reference to a paragraph as the following is true:The numbered paragraph is not in a tableSection is not the first paragraph of the first cell of the paragraphSEction is the last paragraph in the cellIn paragraph contains no text except the numberIf all the above rules apply, Word creates an incorrect bookmark for the
cross-reference as explained and illustrated below. Note that the rules apply to the two examples illustrated above. In the first example, the numbered paragraphs in the Column. In the second example, the numbered paragraphs in the first cell of the row are. When you insert a cross-reference to the numbered item, _Ref as Created in Word, enclose only the text in the destination
paragraph. However, when the above rules apply, Word creates a bookmark that encloses the entire row where the paragraph is found, and the cross-reference shows the number of the first paragraph of the bookmark. This means that the inserted cross-reference shows which number exists in the first paragraph of the first cell of the row instead of the number you selected. If the
first paragraph of the first cell is not numbered, the cross-reference shows 0. Therefore, the cross-references in the illustrations above 0 instead of 1. and A instead of 2.If a cross-handed, numbered paragraph is the first paragraph of the first cell in a row, the bookmark will still be incorrect, but you will not notice because the cross-reference would retrieve the number of the correct
paragraph in that situation. If a cross referenced numbered paragraph is not the first paragraph of the first cell of a row, but if the first paragraph of the first cell of the row is accidentally numbered with the same number as the selected target of the cross-reference, you will not notice the problem either, but the cross-reference will actually show the number from the wrong
paragraph. The bookmark issue is illustrated below. The field codes for the first REF field appear (above the arrow) and the bookmark is selected in the Bookmark:To prevent or correct the problemTo prevent the problem With incorrect cross-references to blank numbered paragraphs in tables, Word must be forced to create correct _Ref bookmarks. You can resolve the issue as
follows:Add a space to the numbered paragraph before creating the cross-reference area will cause Word to create a correct bookmark and thus a correct cross-reference. You can add any character other than a space, but a space will not be visible in the final document. See the illustrations below:The solution with the space is illustrated only with one of the two examples above,
but it will work in all cases. If you have already inserted cross-references that are incorrect due to incorrect bookmarks, it is most likely that the simplest solution corrects each instance by adding a space to the target section as shown above, and then deleting the wrong cross-reference and creating a new cross-reference. Alternatively, you need to correct each of the wrong
bookmarks. To correct your bookmarks, follow the principles shown in the videos that come with issue 1, issue 2, and issue 3. You can manually delete the old and crazy bookmarks if you want to get rid of these bookmarks. They do not hurt, but they rotate the collection of bookmarks. Note that the DocTools CrossReferenceManager add-in can automatically prevent or resolve
this issue. As explained and shown in videos for Issues 1-4 above, a cross-reference is a field that points to a bookmark. The cross-reference shows the contents of that bookmark. If, for you've added a cross-reference to a heading, bookmark the heading text, and the cross-reference field contains the name of the bookmark, prompting Word to show what's in the bookmark.
When you update fields in Word, one or more cross-reference fields may appear to display the text Error! Reference source not found as illustrated below:This issue occurs if the bookmark that the cross-reference refers to no longer exists. This will be the case if you have deleted the text that the cross-reference pointed to. When you delete content in Word, a bookmark in this
content will also be gone. As a result, all cross-references that refer to a bookmark that no longer exists can no longer display relevant content. Instead, such fields will display the error text Error! The reference source could not be found. The source in this case was the deleted bookmark area. The problem also occurs if, for example, you have a cross-reference to a heading, and
you select the entire heading and type a new heading instead. The moment you start typing, the old heading is deleted, and the _Ref bookmark used by the cross-reference field to display the correct content will be gone. See below how to prevent the problem. To edit a text with cross-references, do not delete the entire text first. Instead, you need to enter the new content of the
existing text, that is, within the bookmarked area, to preserve _Ref bookmark. The videos for Problems 1-3 above will help you understand the details. If you need to delete content that is cross-referenced elsewhere in the document, you need to resolve the issue by removing the erroneous cross-references afterwards. See below. How to resolve the problemDelete the incorrect
cross-reference and insert a new and new cross-reference instead. If the cross-reference is no longer required, simply delete the cross-reference and edit the surrounding text as needed. Note that the DocTools CrossReferenceManager add-in can automatically find and help you resolve this issue. You can experience the following: The document looks great — you've checked
everything. Then, print the document or create a PDF, and now one or more cross-references display incorrect or incorrect content. Other types of fields may also display incorrect or incorrect content. As explained and shown in videos for Issues 1-4 above, a cross-reference is a field that points to a bookmark. The cross-reference shows the contents of that bookmark. But note
the following: Cross-reference fields are not updated automatically while editing a documentYou must force the fields to update, for example, by selecting all (Ctrl+A) and pressing F9 to update the fields. If you have not updated fields before printing or creating a PDF, and if the File &gt; Options &gt; View &gt; Update Fields before printing option is enabled, all fields are updated
when you print documents. Since of a PDF file is also a type of print, the fields are also updated when you create a PDF file. As a result, you may now see one or more fields with errors or incorrect content that you didn't see beforehand. The printout or PDF shows what the real content of the cross-reference fields (and other fields) is. The problem is not in the printout or PDF – the
problem is that you made yourself make sure to update fields. There may be special situations where you have good reason to print without having fields updated. In this situation, you can temporarily disable the File &gt; Options &gt; View &gt; before printing option. However, I recommend that you always update fields before the final check of your documents. The following
illustration shows where to find the Update Fields before Printing option (the Word Options dialog box is set to a small size here). To prevent the problem, turn off the File &gt; Options &gt; Display &gt; update fields before printing option. I do not recommend that since it can give you a false picture of what is really in your documents. If you have the option disabled, and if the
document is opened and printed by other users with the option enabled, the fields are updated when they print or create a PDF. I recommend that you always make sure to update fields before the final check of the document. In case of cross-reference problems, you can resolve them by following the procedures shown in issues 1-5 above. Then, printing and creating PDF will
show no surprises when it comes to cross-reference fields. To resolve the issueBefore you print or create a PDF, you must update the fields in the document. Check all cross-references (and other fields) and correct any cross-reference errors by following the procedures shown in Issues 1-5 above. Then, print the document or create a PDF as needed. Note that the DocTools
CrossReferenceManager add-in helps you update all fields in documents. In addition, it can prevent or fix the different types of cross-reference problems. The videos included with Issue 1, Issue 2, and Problem 3 above describe how to correct errors in cross-reference fields by correcting the _Ref bookmarks that the cross-reference fields point to. You can also delete each wrong
cross-reference field and replace it with a new field. However, this would leave errors _Ref bookmarks in the document and thus the root collection of bookmarks. Related informationYou can learn more about cross-reference fields in the article How cross-reference fields in Word work on wordaddins.com site. Website.
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